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About This Guide 

This guide shows you how to install and configure the FileOnQ Database and Desktop software. It is 
assumed that you are familiar with Microsoft SQL Server and the Windows operating system, as well as 
concepts related to computer networks and security. It is also assumed that Microsoft SQL Server is 
already running in your environment. For information on SQL Server installation and setup, see your 
SQL Server documentation. 

The installation procedure consists of the following 10 steps.  

Step 1: Verify Server and Client Requirements ........................................................................................... 4 

Step 2: Install an OnQ Database on your Server ......................................................................................... 5 

Step 3: Install the FileOnQ Portal Administrator (New Installations Only) ................................................. 7 

Step 4: Install OnQ Administrative Tools (New Installations Only) ............................................................. 8 

Step 5:  Create an OnQ Application ............................................................................................................. 9 

Step 6: Enable Access to the OnQ Application .......................................................................................... 11 

Step 7:  Request and Apply the License ..................................................................................................... 13 

Step 8:  Install OnQ Desktop Software ...................................................................................................... 15 

Step 9: Install Peripheral Hardware to Use with FileOnQ ......................................................................... 16 

Step 10:  Install Optional Modules ............................................................................................................ 17 

Overview of the OnQ System  

The OnQ system is a 32-bit, Windows-compliant application that uses Microsoft SQL Server as its 
backend database. It is often used in conjunction with peripheral hardware such as barcode scanners. 
The OnQ system may include the following optional modules: 

eDocs: Electronic documents stored in a SQL database repository. 

WebView: A browser-based application that runs on Internet Explorer version 6.x and later. It is a .NET 
application that runs on an Internet Information Services (IIS) server. 

MobileOnQ: An application that works in conjunction with Motorola's portable MCxx PDA to allow 
transactions from remote locations. The mobile device can use a wireless network or a 3G network. It 
runs by way of web services installed on your IIS server.   

http://www.fileonq.com/
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Step 1: 

Verify Server and Client Requirements 

 

 

Before you begin the installation procedure, make sure that the server and all client machines meet the 
minimum system requirements.  

For server requirements, see Server Hardware and Software Requirements. 

For client requirements, see Client Machine Requirements. 
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Step 2: 

Install an OnQ Database on your Server 

 

 

These instructions assume that Microsoft SQL Server is already running in your environment. For 
information on SQL Server installation and setup, see your SQL Server documentation.  

Two options are available for installing an OnQ database: 

• Restore an existing OnQ database and install it on your SQL Server machine.  

• Create a new, empty database. 

OPTION 1: Use the DBRestore utility to restore an existing OnQ database on your 
SQL Server machine 

Use this option if FileOnQ technical support created your OnQ database and supplied a database 
backup file. You can also use this option if you want to copy your existing OnQ database as a starting 
place for deploying a new database, or if you are splitting your first database into two. 

The DBRestore utility creates an SQL script and allows you to run the SQL statements directly from the 
utility. Alternatively, you can copy the SQL script and run it with SQL Server Management Studio to make 
modifications, such as changing the user name.  

1. Move the backup file to the SQL Server machine. The file must physically reside on this server. 

2. Download the DBRestore utility (DBRestore.exe, 84.0 KB) from the following link: 
https://www.onlinefilefolder.com/2sk8ZbNWK5I1aF 

3. Run DBRestore. The FileOnQ Restore window appears. 

 

http://www.fileonq.com/
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4. In the Database Name field, type a name for the new database. 

5. Click the first ellipsis button to browse to the database backup file.  

6. Click the Connect button to establish a connection with the SQL Server.  
A login window appears. Supply the server name and the System Administrator (sa) login and 
password. Click OK. 

7. If you are running the 
DBRestore utility to 
replace an earlier 
installation of the OnQ 
database, select the Replace existing database if exists check box. Otherwise, keep the default 
settings.  

8. Click Restore. Watch for 
messages that indicate a 
successful restoration. Click 
Close. 

 

 

 

OPTION 2: Create a blank OnQ database for a new project 

Use this option to create a new, empty OnQ database. It will not contain any fields for user data. After 
you finish the installation procedure, use the OnQ Profiler to define all user fields.  

The install files received from FileOnQ include an installation script that will build an empty OnQ 
database.  

NOTE   You must use an installation script 
that is compatible with the version of your 
database. Send an email message to 
support@fileonq.com to get the correct 
script to run on your server. Include the 
version of your OnQ Desktop software, 
which appears at the top of your login 
screen.  
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Step 3: 

Install the FileOnQ Portal Administrator 

(New Installations Only) 

 

 

The installer file package from FileOnQ includes a SQL script to install the Portal Administrator on your 
SQL Server machine.  

If you have previously installed an OnQ (version 6 or greater) database, the FileOnQ Portal Administrator  
is already installed on your SQL Server machine. This step is required only if this is the first OnQ 
database ever installed on your system, or if you are establishing another administrative entity for an 
OnQ database that will not be accessed by current OnQ users.  

1. In the FileOnQ installer file package, find the SQL script for installing the Portal Administrator, and 
then run the script from SQL Server Management Studio.   

2. Configure the access to this program: go to C:\Program Files\FileOnQ\FQPortalAdmin and open the 
FQPortalAdmin.exe.config file with a text editor. 

3. Type the correct values for dbportalserver, dbportaldbname, dbportaldblogin, and 
dbportaldbpassword. Save and close the file. 
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Step 4: 

Install OnQ Administrative Tools 

(New Installations Only) 

 

 

If you have previously installed an OnQ database, the administrative tools are already installed on a PC 
in your environment. This step is required only if this is the first OnQ database ever installed on your 
system, or if you are establishing another administrative entity for an OnQ database that will not be 
accessed by current OnQ users.  

The installer file package from FileOnQ includes one installer (FQDesktopxx.msi). This file installs the 
Desktop Client and the administrative tools.   

 

1. Locate the .msi file from the 
FileOnQ installation files.  

 

2. Double-click the .msi file, 
click through the first few 
screens of the Setup 
wizard, and then select 
Custom Setup. For both 
the application and the 
administration tools, select 
This feature, and all 
subfeatures, will be 
installed on local hard 
drive. Do not use the 
default (with the red X in 
the window), which skips 
the administrative tools.  

3. Click Next through the rest 
of the installer windows, 
and use the defaults for 
the remaining settings. 

 

 

After the installation is complete, you should see a New Programs Installed message on your Windows 
Start menu. The FileOnQ folder will contain the Desktop, Administrator, and Profiler programs.  

http://www.fileonq.com/


Step 5:  

Create an OnQ Application 

 

 

You use the Portal Administrator to create an OnQ application. 

1. Click Start > FileonQ > FQPortalAdmin > FileonQ Portal Administrator. 
The Portal Administrator dialog box appears. 

2. Click the Create a new Application icon, located at 
the upper-left corner of the window. 
The Application dialog box appears.  

3. Enter values into the following fields and click OK: 

• Application Name: Enter a unique name for 
the application. 

• Select the Active check box. If you are licensed for and want to enable web browser access 
(WebView), select the Enable Web Access checkbox.  

• If you want to use Active Directory to define and maintain security groups, select the Use Active 
Directory for application authentication checkbox. 

• Server Address, Database Name: Enter the machine name of the server, and the name of the 
OnQ database that you created or restored in Step 2 on page 5. 

• Login, Password: Enter login credentials.  
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The new application now appears on the Portal Administration dialog box. 
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Step 6: 

Enable Access to the OnQ Application  

 

 

When client Desktop users log into an OnQ application, the system reads a file called ServerProfiles.xml. 
This file identifies the location of the Portal Administrator, which maintains your site’s OnQ application and 
the credentials required for users to access it.  

If your organization uses more than one OnQ 
application, users indicate which application they want 
to log into by choosing it from the Connection Profile 
drop-down list on the Login window. 

Your workstation’s C:\Program Files\FileOnQ\FileOnQ 
<version> folder contains a default ServerProfiles.xml 
file. You must edit it, by using the FileOnQ Server Profiles Administrator (Admin Tool), to point to the 
Portal Administrator.  

1. From the Windows Start menu, start the FileOnQ 
Administrator application. 
A login screen appears. 

2. Log in with fileonqadmin as your initial login. 
FileOnQ Support will provide your initial password. 
Click OK.  
The Admin Tool launches. 
  

 

 

 

 

 

 

3. For a new installation, you should select a network location to store the ServerProfiles.xml file. To set 
the location, from the Admin Tool, select File > Change Location, and then specify the network 
location.  
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4. From the Admin Tool, select File > Edit Portal to edit the ServerProfiles.xml file. 
The FileOnQ Portal Database window appears. Edit the fields as follows:  

• Profile Name: Descriptive name to identify the 
application. If your site maintains more than one 
OnQ application, this is the name that will appear 
in the Connection Profiles drop-down menu 
when users log in.   

• Server Name/Address: Machine name and 
static IP address of the SQL Server machine. If 
there is an instance specified on your server, you 
must include that instance name in this field. 

• Database Name: Enter the value FQPortal.  

• Login ID: Enter the value fileonquser. 

• Password: Supplied by FileOnQ Support in the 
DBRestore utility or by your database 
administrator. 

5. Click OK. Click the Save icon. 

http://www.fileonq.com/
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Step 7:  

Request and Apply a License 

 

 

Every OnQ application must be licensed. A new OnQ application will function with no license—in “demo 
mode”—until the database contains 50 records. At that time, you must load a valid license file.  

After you request a license file, FileOnQ sends you an encrypted license file as an attachment to an email 
message. The filename extension for the license file is .lic.  

Request a License File 

1. From the Windows Start menu, log into the Admin Tool. 

2. From the Admin Tool, click the profile name that you are requesting a license 
for.

 

3. Click the Administer Application icon  
Or, 
From the menu at the top of the window, select Profile > Administer Application.  
A login window appears. 

4. Log into the application. The login ID is System. The password is supplied by FileOnQ support. 

5. Click the Request License button on the right side of the window that appears. 
The License Request window appears. 

 

6. Fill out the fields with your information. Click Request. Save the request file with a meaningful name 
and the extension .req. 

http://www.fileonq.com/
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7. A message tells you that a request file has been created. Send an email message to 
License@fileonq.com and include the request file as an attachment. 

Apply the License File 

1. When you receive the email message that contains the license file, save it to a convenient location. 

2. Sign into the FileOnQ Administration tool again, select the profile to apply the license to, and 
then click the Administer Application icon.  

3. Sign in and click the Load License File button. 
The Select License File dialog box appears. 

4. Navigate to the location where you saved the .lic file, select the license file, and then and click Open. 
You should receive a success message. 

http://www.fileonq.com/
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Step 8:  

Install OnQ Desktop Software 

 

 

All computers that need the Desktop software can install it from the FQDesktopxx.msi file, described on 
page 8. All of the default settings should be used, which means that the Administration Tools will not be 
installed. A Windows user with administrative permissions should perform the installations. 

If you see an error message that says the 
ServerProfiles.xml file was not found, you 
must set the path to this file. From the Admin 
Tool, select File > Change Location, and 
then specify the network location. 
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Step 9: 

Install Peripheral Hardware to Use with FileOnQ 

 

 

Any computer that has attached hardware—such as a barcode scanner or an electronic signature pad—
must have those devices installed and configured while the administrator is still logged in. 

For installation instructions, see the documentation provided with your hardware devices.  

To configure hardware devices, from the main menu, select Tools > Options > This Workstation. Use 
the tabs to find the settings for the particular type of device you want to configure. 

 

NOTE   FileOnQ uses Windows printers, either locally attached or network printers. Although there is no 
setup inside FileOnQ for any printers, you may have received some configuration information about 
barcode label printers that will be useful in setting them up to work with FileOnQ. 
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Step 10:  

Install Optional Modules 

 

 

If your system includes eDocs or WebView, you must set up those optional modules. 

Install and Configure eDocs 

With the bundled eDocs module, users can store electronic files in a SQL database repository. To enable 
this functionality, you must define at least one storage device and an associated SQL database. 

1. Start the FileOnQ Administrator program and select the profile for the database to which you want to 
add the eDocs Repository. Click the 
Administer the application icon. 

2. Log in to the database using administrator 
credentials.  

3. From the window that appears, click 
eDocs Manager. 

 
4. Select SQLServer and then click the Add a new 

storage device under the selected connector icon.  
 

 
 

5. Assign a short name and a long name to the 
storage device. Click OK. The storage device now 
appears in the list under SQLServer. 
NOTE    Over time, you might add multiple 
storage devices to an eDocs Repository. Consider 
an appropriate naming convention so users will be 
clear where documents are being stored.  
 

 

6. Select the new storage device and click the 
Configure Connector icon. 

 

 

7. You are asked whether you want to run the 
Database Create wizard. Click Yes. 
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8. Enter the name (and instance if 
one exists) of the SQL Server that 
will host this repository. Enter the 
sa password for this SQL server. 
Click Next. 

 

 

 

 

 

 

 

9. Complete the fields to define the database and the locations of the data and log files. Choose 
appropriate starting sizes for the data and log files. These will be set to grow automatically. 

NOTE   The User Login ID is usually the same SQL login that was established for the main FileOnQ 
database. If this eDocs Repository is on the same SQL Server, it is convenient to use the same SQL 
login and associated password. 

 

10. Supply the full path to the DATA and LOG files for this database, the SQL login and password, and 
the initial file sizes. 
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11. Click Create. You will see the progress and completion messages in the window. Click Close. 

12. The eDocs Connector Configurations window will be displayed with the previously chosen 
parameters. Click OK. 

13. Click the Settings button to go to the FileOnQ database settings window. 

 

 

 

 

14. In the database settings window, make sure the Document Tab Caption field contains a value, such 
as “Documents”. Also, we recommend that you select the Auto-assign Document Barcode check 
box. Save and close the FileOnQ Administrator. 

 

15. You may choose to add document types to the FileOnQ 
application to organize the stored eDocs by category. An 
administrator can log in to FileOnQ and, from the Data menu, 
select Document Collection. 
The Document Collection Maintenance window appears. 

16. To add new document types, click New. The system will supply 
consecutive decimal numbers to distinguish between the 
different types. 

 

 

 

 

 

. 
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Technical Support  

Need Assistance?  

Please call (206) 575-3488 or (800) 603-6802 (option 4) for Technical Support.: 

Or send questions to: 
support@fileonq.com 

See us on the web at: 
www.fileonq.com 
www.evidenceonq.com 
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